rain, rain go away…

I don’t remember if I’ve mentioned this before (though I’m sure I probably have…), but every single race I had back in 2010, with 1 single exception, was in the cold and the rain. It was absurd. I mean, to the point where you couldn’t help but wonder if the big guy upstairs was trying to tell me something. Like maybe I shouldn’t be doing triathlons or something. Since we’re here, 2 years later, you can assume (correctly) that 1) I am stubborn and 2) I don’t listen very well.

The night before my first-ever 70.3, we camped in a supposedly racers-only campground (that’s a whole ‘nother story…) and there was a seriously epic thunderstorm. Complete with booming, holy crap, right-on-top-of-you claps of thunder, brilliant flashes of lightning and some serious driving rain. Big ol’ rain drops, pounding heavy on the tent. Not that I was sleeping so very soundly to begin with what with the pre-race nerves and such, but I remember waking up around 2 a.m. and saying out loud to my also awake hubby, “Seriously?!” And then thinking something along the lines of “Not again,” “Why me?” followed by “Un-freakin’-believable.” Which was then followed by a series of words that are not appropriate to list here and a list of potential accident scenarios that could happen between 2 a.m. and the 7 a.m. start that would be ‘ok’ reasons to NOT do the race (should it decide to keep on storming, that is). You know, along the lines of somehow slipping on something and breaking my ankle getting out of the tent in the a.m. Or maybe I would get attacked by the mythical grand Elk-asaurous Rex and his partner in crime, Big foot.

The chilly swim during the “calm between the storms” – Ghost Reservoir, AB, CAN. Calgary 70.3, August 2010

In the end, it ended up ok. At least in hindsight I can say it did. The water was freezing, thanks to downpour. It stopped raining in time for bodymarking and the swim (where it wouldn’t have mattered seeing as we were already cold and wet).

And then started again while I was on the bike (where it definitely DID matter). But the weather was perfect (by my standards) on the run – overcast and cool. 60-something. ­I guess there was a silver lining. It just took ¾ of the race day for me to find it.I was reminiscing about this earlier this evening as I was being drenched by a sudden downpour that consumed the last 18 miles of my 40 mile bike ride tonight. (According to weather.com, there was only supposed to be a 30% chance of rain until 9 p.m. tonight, so while I figured I might get some sprinkles, I didn’t think I was taking THAT big of a chance… though clearly I was wrong.) The deluge brought back memories – Ironman is in town this weekend, and I can only imagine the thoughts that are going through the athletes’ minds tonight as they all hope and pray for better weather on Sunday. Because you know, it’s not like there aren’t enough battles in a 70.3 or 140.6 mile long day. Clicking mile after mile under your own power present plenty of challenges without rain in the equation.

Tonight there was nothing to do but laugh and shake my head at the downpour. I had to get back to my car; I had no choice but to deal with the rain. Race day weather is just like that. You’re ready for the event. You’re trained up. Hopefully you did some training in the elements because let’s face it – the weather gods are not always nice come race day. There’s not a thing you can do about the weather but curse it or just grin and bear it. And if you’re unfortunate enough to be signed up for a race that I’m doing, you can bet that you’re gonna get rained on at some point in the day.

But I sure do hope that it clears up for the racers by Sunday…

My view of the storm I was stuck in… glad I only had it for 20 miles and not 100 miles! Since you can’t see the actual raindrops in this photo, you’ll just have to take my word for it.

Advertisements

2 thoughts on “rain, rain go away…

  1. Hello just wanted to give you a brief heads up and let you know a
    few of the pictures aren’t loading properly. I’m
    not sure why but I think its a linking issue.
    I’ve tried it in two different web browsers and both show the same outcome.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s